Haven error from latkai

Ask and answer any and all questions pertaining to Salem's game-play.

Haven error from latkai

Postby ThiccBones » Sat Jan 29, 2022 10:16 pm

Hello, returning player hoping to use the beautiful auto inventory sorting and other great features of latkai's client. When i launch the updater (i have tried older ones as well) it says haven error. Normal unmodded salem runs perfectly fine though. Any suggestions?

Name Value
mem.free 38,809,064
mem.max 805,306,368
mem.total 100,663,296
thcl haven.HackThread
thnm Haven main thread
Exception chain
Index -1 out of bounds for length 1

Class Function File Line
jogamp.opengl.windows.wgl.awt.WindowsAWTWGLGraphicsConfigurationFactory chooseGraphicsConfigurationImpl WindowsAWTWGLGraphicsConfigurationFactory.java 170
javax.media.nativewindow.GraphicsConfigurationFactory chooseGraphicsConfiguration GraphicsConfigurationFactory.java 422
javax.media.opengl.awt.GLCanvas chooseGraphicsConfiguration GLCanvas.java 1403
javax.media.opengl.awt.GLCanvas addNotify GLCanvas.java 617
java.awt.Container addNotify Container.java 2804
java.awt.Window addNotify Window.java 791
java.awt.Frame addNotify Frame.java 495
java.awt.Window pack Window.java 829
haven.MainFrame <init> MainFrame.java 245
haven.MainFrame main2 MainFrame.java 438
haven.MainFrame access$100 MainFrame.java 62
haven.MainFrame$8 run MainFrame.java 507
java.lang.Thread run Thread.java 833
Posts: 6
Joined: Sun Dec 31, 2017 4:47 am

Re: Haven error from latkai

Postby ThiccBones » Mon Jan 31, 2022 1:20 am

Problem fixed! I removed my most recent update of java development kit and instead downloaded version 11 and changed my jre to 64 bit. I don't know which one solved it but im good now.
Posts: 6
Joined: Sun Dec 31, 2017 4:47 am

Return to Help!

Who is online

Users browsing this forum: No registered users and 5 guests