Mac User - right click won't work

Ask and answer any and all questions pertaining to Salem's game-play.

Mac User - right click won't work

Postby Sorcha » Sat Sep 30, 2017 1:27 am

I'm using a Macbook and can't get started because the game isn't registering my mouse clicks. I've googled and found that this is a common problem, but I have found no way to fix it. I've downloaded both custom clients, but I can't get either of them to work.

Any ideas?
Last edited by Sorcha on Sat Sep 30, 2017 8:00 am, edited 1 time in total.
Posts: 2
Joined: Sat Sep 30, 2017 12:03 am

Re: Mac User - right click won't work

Postby Propulsion » Sat Sep 30, 2017 3:43 am

i had this problem. Using Enders client worked for me.

User avatar
Posts: 347
Joined: Tue Feb 25, 2014 11:35 pm

Re: Mac User - right click won't work

Postby Sorcha » Sat Sep 30, 2017 7:56 am

Well, as I wrote, neither that nor the other custom client work.
Posts: 2
Joined: Sat Sep 30, 2017 12:03 am

Re: Mac User - right click won't work

Postby TotalyMeow » Sun Oct 01, 2017 2:41 am

I seem to recall this problem is caused by the wrong color depth, that you have to set your Mac to 32 bit. But client problems are not my forte so this may or may not work.
Community Manager for Mortal Moments Inc.

Icon wrote:This isn't Farmville with fighting, its Mortal Kombat with corn.
User avatar
Posts: 3782
Joined: Thu Jun 05, 2014 8:14 pm

Re: Mac User - right click won't work

Postby Carca » Mon Oct 02, 2017 6:38 pm

I tried to play on my Mac laptop while away on holiday. I had the same problem and spent a lot of time looking through all the old posts on this subject as well as Mac and Java help forums.
By the end of the week I gave up after trying every fix suggested and a lot of other stuff that wasn't.
User avatar
Posts: 31
Joined: Sun Apr 07, 2013 5:53 pm

Re: Mac User - right click won't work

Postby BucketManWillie » Mon Oct 02, 2017 11:21 pm

This seems to be a problem with all clients... the color depth thing is the most common answer but there seems to be no real way to change it... if you run it in "Parallels" with Windows 10 on a Mac, all clients will work just fine... you of course have to install the windows version of jdk and such ...bleh. No love for Mac Users...
Posts: 26
Joined: Sat Mar 23, 2013 9:03 am

I can't move

Postby Olympress » Thu Oct 05, 2017 4:53 am

Hello! I just tried downloading the game and am at the docks where I have to right click either the woman or man. I'm playing on a macbook air (ew I know) and I can't click to move. W, A, S and D work but the clicking doesn't. I've tried switching my mouse, too. Any help would be greatly appreciated!

Thank you for your time.
Posts: 1
Joined: Thu Oct 05, 2017 4:24 am

Re: Mac User - right click won't work

Postby Kandarim » Thu Oct 05, 2017 8:19 am

Unfortunately, Mac has since removed the option to control color depth for your screens (for the record, I'm unsure whether this is the actual cause, but it did cause the same issues a long time ago).

You can try things like 'Display Maestro' to force a certain bit depth (or at least check that the current depth is 32 rather than 16)
I have neither the crayons nor the time to explain it to you.
JC wrote:I'm not fully committed to being wrong on that yet.
User avatar
Posts: 5319
Joined: Mon Jan 21, 2013 4:18 pm

Re: Mac User - right click won't work

Postby Lansett » Fri Dec 15, 2017 7:26 pm

I wanted to try Salem on my work devoted MacBook Pro.
On Display Maestro I switched from 32bits Retina to 32bits non-Retina and I still can't click on the environment, only the UI (on Latikai's and Ender's)
I'm clueless on MacOs because I'm quite new to it, so I doesn't have much more to add :/
User avatar
Posts: 239
Joined: Tue Nov 20, 2012 3:14 pm
Location: France

Re: Mac User - right click won't work

Postby vysen » Fri Dec 15, 2017 7:34 pm

Both custom clients require you to install a JDK to run them. I forget if the default does, but that doesn't matter.

If you installed a JDK you need to delete the folder from your Mac. It'll be under Java and have some sort of folder name like "JDK 1.8 etc etc etc" Just completely delete the folder.

Then go here and download this and run it:

At this point Ender's client should run and let you use your mouse. I have noticed at times the keyboard will quit working. If you restart the client this will be fixed.

Latkai's sometimes works, sometimes it doesn't boot past the updater. It's finicky to get these to work, but this should get things "playable".

The two programs to let you "change your color depth" seem to no longer do so, or this no longer works, plus they cost money. You're probably best to avoid them unless someone can chime in here verifying the process to use these and get the clients functioning because It does seem outdated info is hanging around.
User avatar
Posts: 114
Joined: Sun Apr 06, 2014 12:57 pm


Return to Help!

Who is online

Users browsing this forum: No registered users and 5 guests