Can't play even after disabling...

Forum for off topic and general discussion.

Can't play even after disabling...

Postby Bugger » Tue Nov 10, 2020 2:51 am

Logged in just for '*****/giggles' and opened a new account... but after jumping through a bunch of '!' and yellow 'WTH' from Norton I still can't enter the game... oh well.

Suppose it's enough to say I miss Salem. Ps2, Lotro, Wow, BD, etc... none of them had the same since of discovery, exploration- just plain adventure I found in Salem. Sucks this game never went mainstream; guess powers that be really saw a competitor and crushed you while they could. Sucks; but that's life I guess.

I whine, but I don't have the time commitment to play any MMO these days. Ps2 which has been out of years... top character <90; even with subs... I just don't have the time! Again, oh well.

Hope your community is doing said. If there's a crowd funder to get you into 22nd century... please let me know. Got a lifetime account with LOTRO that I never play... hell I tried tonight...and I just gave up and tried logging in here.

Says a lot right there.

Posts: 2
Joined: Tue Nov 10, 2020 2:43 am

Re: Can't play even after disabling...

Postby Taipion » Tue Nov 10, 2020 8:52 am

This should be under help.

Try adjusting your java security settings, google that if necessary, add exceptions for the games URLs there, then try again.
Need something? Here is my Shop (Including some useful info for new/returning players at the bottom of the first post)
Posts: 2645
Joined: Fri Mar 08, 2013 4:12 pm

Return to City upon a Hill

Who is online

Users browsing this forum: No registered users and 5 guests