Java Security Settings

Forum for bugs and technical problems.

Re: Java Security Settings

Postby maxcolby » Sat Sep 17, 2016 11:39 am

I just downloaded the client today and was having the same issue.
Was required to update java and then was told my security settings were too high.
I added the two exceptions mentioned earlier in the thread but they didn't work.
The exception works.

You get this before the client opens.


so yeah.
Confirming that works with windows 10 and the newest(as of 9/17/16)java.
Posts: 1
Joined: Sat Sep 17, 2016 11:26 am

Re: Java Security Settings

Postby Kandarim » Sat Sep 17, 2016 12:16 pm

Weird, I've pm'ed John/Meow about this issue to make sure they notice - maybe the RSA key expired or something. Kind of annoying if you don't know about this.
I have neither the crayons nor the time to explain it to you.
JC wrote:I'm not fully committed to being wrong on that yet.
User avatar
Posts: 5319
Joined: Mon Jan 21, 2013 4:18 pm

Re: Java Security Settings

Postby deutch » Sun Jun 04, 2017 10:48 pm

I do not work in Windows 10. I write something about open GL, although all the drivers have been updated.
God will judge!(Priest)
Posts: 69
Joined: Mon Jul 01, 2013 9:21 am
Location: Plymouth

Re: Java Security Settings

Postby DanteDigital » Sun Dec 03, 2017 12:05 pm

I get the java security alert when I launch the game, I tell it to run the application, log in then black screen and nothing happens.

Tried 32 and 64 bit versions of java, added all the security exceptions ever mentioned in this thread including, turned off both router and windows firewall and antivirus, still no luck.

I am running windows 10 64bit and the latest version of java (8.151).

Any tips on where to go from here?
Posts: 1
Joined: Sun Dec 03, 2017 11:11 am

Re: Java Security Settings

Postby Motylop » Sun Dec 24, 2017 11:07 am

I've got the same problem:
"Salem" -> Log in -> Authenticating -> Conecting -> BLACK SCREEN....

Posts: 24
Joined: Thu May 02, 2013 7:20 pm

Re: Java Security Settings

Postby LordPicasso » Sun Feb 04, 2018 1:05 pm

java.lang.ArrayIndexOutOfBoundsException: -1
at java.desktop/java.awt.Container.addNotify(Unknown Source)
at java.desktop/java.awt.Window.addNotify(Unknown Source)
at java.desktop/java.awt.Frame.addNotify(Unknown Source)
at java.desktop/java.awt.Window.pack(Unknown Source)
at haven.MainFrame.<init>(
at haven.MainFrame.main2(
at haven.MainFrame.access$100(
at haven.MainFrame$
at java.base/ Source)
How to fix it? Any idea?
Posts: 1
Joined: Sun Feb 04, 2018 12:56 pm

Re: Java Security Settings

Postby Tarzan1983 » Fri Mar 02, 2018 11:56 pm

I can't figure this out and I have 3 exceptions with java I see the salem pop up and in a flash it's gone any help I have windows 10 and the latest version ofg java and i'm running it with internet explorer any help would be nice
Posts: 17
Joined: Mon Jun 09, 2014 2:58 am

Re: Java Security Settings

Postby u4ikrob » Thu Aug 01, 2019 3:29 pm

Im with you Tarzan -- Been playing Salem up until last week - Win10 - Fully patched Java --
New Java patch came out and now it wont connect to the client -- Latest seems to be tied to an Fatal Error exception being created in Java at launch and shutting the client down

Here's a clip of the error log -- When the Salem client is launched

# A fatal error has been detected by the Java Runtime Environment:
# EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x00000000, pid=3936, tid=0x0000234c
# JRE version: Java(TM) SE Runtime Environment (8.0_221-b11) (build 1.8.0_221-b11)
# Java VM: Java HotSpot(TM) Client VM (25.221-b11 mixed mode windows-x86 )
# Problematic frame:
# C 0x00000000
# Failed to write core dump. Minidumps are not enabled by default on client versions of Windows
# If you would like to submit a bug report, please visit:
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

Looking for a little help with resolving the launch issue - Dev's ?? Anyone??.... Bueller...
Posts: 1
Joined: Mon Jul 01, 2019 9:49 pm

Re: Java Security Settings

Postby Taipion » Thu Aug 01, 2019 4:52 pm

Wow what a necro.... did you try to uninstall java, and do java 1.7 or 1.8 and no auto updates?

Did you try to google the error message and find a general connection to win10 through the google results?
Need something? Here is my Shop (Including some useful info for new/returning players at the bottom of the first post)
Posts: 2656
Joined: Fri Mar 08, 2013 4:12 pm


Return to Bugs & Technicalities

Who is online

Users browsing this forum: No registered users and 2 guests