LowGfx.res mod

Forum for game modifications and custom clients.

LowGfx.res mod

Postby Chiprel » Tue Dec 04, 2012 8:26 am

Update 19 March 2013
Ridges textures resized.
For best performance install Usernm 11tile ground texture pack after this.

Download link:
https://dl.dropbox.com/u/95535397/low/Salem190313.zip




Previous update inside spoiler.
Update 26 Jan 2013
All ground textures tiles resized.
Big thanks to Usernm for repacking all of non working ground textures with his superior script :)

Download link:
https://dl.dropbox.com/u/95535397/low/Salem260113.zip


PS. For theoretical best performance boost, use Usernm mod:
viewtopic.php?f=11&t=3820
While if you want to have performance boost and good looking salem. Use this one :P


Old post below


After wondering for so long..what the hell is causing my fps to be so low(terribad gfx card Yo!) I started experimenting:

/
Welcum to Salem:Minecraft edition

Image
Image


While it was just mistake while having fun with java it turned out that I found the culprit. My FPS skyrocketed. Texture scalling was causing great problems for my gfx card.
So to make it playable and not so ugly looking I resized all ground textures to 1/4 original size(big fps boost for me) and all terobjs (some fps boost). (graphic quality change is barely visible on medium zoomout)

FPS pre and after change:
FPS pre change(left bottom corner):
Image

FPS after change(left bottom corner):
Image


Overall I gained around 10-15fps.

Link to mod:
https://dl.dropbox.com/u/95535397/low/Salem.zip

It contains:
-custom_res directory with resized/scaled down textures
-run.bat (with -d to enable debug mode)


How to install:
Unzip Salem.zip into "yourUSER/". If you do it correctly then custom_res will be in: "yourUSER/Salem/" and run.bat in "/yourUSER/Salem/bin/".
Doubleclick run.bat in yourUSER/Salem/bin/ if it won't work open run.bat with text editor and edit path to java.
From this:
javaw.exe -Xms512m -Xmx1024m -Dhaven.resurl="http://plymouth.seatribe.se/res/" -Dhaven.defserv="plymouth.seatribe.se" -jar salem.jar -d
To something like this(java might be in different place on your pc so find where it is):
"C:\Program Files\Java\jre7\bin\javaw.exe" -Xms512m -Xmx1024m -Dhaven.resurl="http://plymouth.seatribe.se/res/" -Dhaven.defserv="plymouth.seatribe.se" -jar salem.jar -d


How to run/test:
Doubleclick run.bat in yourUSER/Salem/bin/ to start salem.
To test if you are gaining any fps with this mod:
-Run game, turn on 'freecam' in options, stand few seconds so everything loads and check FPS in left bottom corner.
-Rename "custom_res" directory in "yourUSER/Salem/" to something like "aaacustom_res" so game won't use low quality textures. Run game again and check FPS.
-to get mod working again just rename your "aaacustom_res" back to "custom_res"

It doesn't matter which ender version you will use this mod will always load. So if you want it gone you have to delete or rename "custom_res" directory.
To see fps counter run game with run.bat and if you wish to just play with lowgfx mod then start with enders updater/shortcut


Big thanks to Ender for making this client and thanks J/Lo for great game and this debug tool :D

PS. If you have good graphic card. Don't even bother installing this. :P
PS2. If you have problems with light/smoke/fire it won't help you at all too.
Last edited by Chiprel on Tue Mar 19, 2013 9:03 pm, edited 6 times in total.
dem M_O_V_E_M_E_N_T_O_A_T_M_E_A_L_C_R_A_C_K_E_R_S
Winner of bracket ( award.
<@TotalyMoo> Mushi, will you be my new lover? :<
User avatar
Chiprel
 
Posts: 778
Joined: Wed Aug 01, 2012 1:25 am

Re: LowGfx.res mod

Postby _Gunnar » Tue Dec 04, 2012 7:48 pm

Awesome. I also gain about 15fps in the forest by using this, from 27fps to about 42fps as a rough estimate :). Thanks!
ImageImageImage
Darwoth wrote:tradewinds is gunnar
Brego wrote:***** STUPID GUNNAR!

great minds
User avatar
_Gunnar
 
Posts: 520
Joined: Wed Aug 01, 2012 9:21 pm

Re: LowGfx.res mod

Postby darnokpl » Tue Dec 04, 2012 9:40 pm

It crashed for me:/

Code: Select all
javax.media.opengl.GLException: java.lang.RuntimeException: Delayed error in resource  (v4), from forking source backed by HTTP res source (http://plymouth.seatribe.se/res/)
   at javax.media.opengl.Threading.invokeOnOpenGLThread(Threading.java:271)
   at javax.media.opengl.GLCanvas.maybeDoSingleThreadedWorkaround(GLCanvas.java:410)
   at javax.media.opengl.GLCanvas.display(GLCanvas.java:244)
   at haven.HavenPanel.uglyjoglhack(HavenPanel.java:385)
   at haven.HavenPanel.run(HavenPanel.java:420)
   at java.lang.Thread.run(Thread.java:679)
Caused by: java.lang.RuntimeException: Delayed error in resource  (v4), from forking source backed by HTTP res source (http://plymouth.seatribe.se/res/)
   at haven.Resource.checkerr(Resource.java:1407)
   at haven.Resource.layer(Resource.java:1292)
   at haven.Resource.layer(Resource.java:1301)
   at haven.Sprite.create(Sprite.java:105)
   at haven.ResDrawable.init(ResDrawable.java:53)
   at haven.ResDrawable.<init>(ResDrawable.java:42)
   at haven.ResDrawable.<init>(ResDrawable.java:47)
   at haven.MCache$Grid.makeflavor(MCache.java:165)
   at haven.MCache$Grid.getfo(MCache.java:177)
   at haven.MCache.getfo(MCache.java:404)
   at haven.MapView$2.setup(MapView.java:383)
   at haven.RenderList.setup(RenderList.java:98)
   at haven.RenderList.add(RenderList.java:135)
   at haven.MapView.setup(MapView.java:495)
   at haven.PView$1.setup(PView.java:126)
   at haven.RenderList.setup(RenderList.java:98)
   at haven.RenderList.setup(RenderList.java:123)
   at haven.PView.draw(PView.java:150)
   at haven.MapView.draw(MapView.java:764)
   at haven.Widget.draw(Widget.java:479)
   at haven.Widget.draw(Widget.java:484)
   at haven.GameUI.draw(GameUI.java:422)
   at haven.Widget.draw(Widget.java:479)
   at haven.Widget.draw(Widget.java:484)
   at haven.RootWidget.draw(RootWidget.java:70)
   at haven.UI.draw(UI.java:144)
   at haven.HavenPanel.redraw(HavenPanel.java:273)
   at haven.HavenPanel$1.display(HavenPanel.java:88)
   at com.sun.opengl.impl.GLDrawableHelper.display(GLDrawableHelper.java:78)
   at javax.media.opengl.GLCanvas$DisplayAction.run(GLCanvas.java:435)
   at com.sun.opengl.impl.GLDrawableHelper.invokeGL(GLDrawableHelper.java:194)
   at javax.media.opengl.GLCanvas$DisplayOnEventDispatchThreadAction.run(GLCanvas.java:452)
   at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:216)
   at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:670)
   at java.awt.EventQueue.access$400(EventQueue.java:96)
   at java.awt.EventQueue$2.run(EventQueue.java:631)
   at java.awt.EventQueue$2.run(EventQueue.java:629)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
   at java.awt.EventQueue.dispatchEvent(EventQueue.java:640)
   at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
   at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
   at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
   at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
   at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
Caused by: haven.Resource$LoadException: Load error in resource (v4), from forking source backed by HTTP res source (http://plymouth.seatribe.se/res/)
   at haven.Resource$Loader.handle(Resource.java:453)
   at haven.Resource$Loader.run(Resource.java:427)
   at java.lang.Thread.run(Thread.java:679)
Caused by: java.io.FileNotFoundException: http://plymouth.seatribe.se/res/.res
   at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1401)
   at haven.Resource$HttpSource.get(Resource.java:382)
   at haven.Resource$TeeSource.get(Resource.java:277)
   at haven.Resource$Loader.handle(Resource.java:447)
   ... 2 more
Image
User avatar
darnokpl
 
Posts: 2019
Joined: Thu Aug 02, 2012 12:10 am

Re: LowGfx.res mod

Postby Chiprel » Tue Dec 04, 2012 10:07 pm

Seems one(or more) graphics got bugged while encoding(used old trav hnh tool this time). Got exactly same report from Gunnar in pm. He said that mod was working fine till he moved to different place and he started crashing.

I tested mod myself on biomes: grass/mapple/badlands/pine and in some big village(tanks guiz) and had no issues with it. Seems I was lucky.
To fix it i'll have to:
a)port an alt to you and see by swapping res files what is causing it
b)or if you don't want my alt on your claim: jump on irc and I'll give you few ideas how to track which .res file might be causing it. Just be sure to tell me later which .res so i can edit zip file from first post :P
dem M_O_V_E_M_E_N_T_O_A_T_M_E_A_L_C_R_A_C_K_E_R_S
Winner of bracket ( award.
<@TotalyMoo> Mushi, will you be my new lover? :<
User avatar
Chiprel
 
Posts: 778
Joined: Wed Aug 01, 2012 1:25 am

Re: LowGfx.res mod

Postby _Gunnar » Tue Dec 04, 2012 10:14 pm

darnokpl, did you happen to crash near to a swamp?
ImageImageImage
Darwoth wrote:tradewinds is gunnar
Brego wrote:***** STUPID GUNNAR!

great minds
User avatar
_Gunnar
 
Posts: 520
Joined: Wed Aug 01, 2012 9:21 pm

Re: LowGfx.res mod

Postby darnokpl » Tue Dec 04, 2012 10:20 pm

_Gunnar wrote:darnokpl, did you happen to crash near to a swamp?


yes I logged out one char near swamp and can't login with this mod:/
Image
User avatar
darnokpl
 
Posts: 2019
Joined: Thu Aug 02, 2012 12:10 am

Re: LowGfx.res mod

Postby Chiprel » Tue Dec 04, 2012 10:34 pm

Can you login there without my custom_res and make printscreen of that biome? So I can see exactly which .res might be causing it. If I recall right we have 2-3 swamp textures :P

For now you can try deleting:
yourUSER/salem/custom_res/gfx/tiles/swamp.res and swamp2.res and see if it changes anything.
dem M_O_V_E_M_E_N_T_O_A_T_M_E_A_L_C_R_A_C_K_E_R_S
Winner of bracket ( award.
<@TotalyMoo> Mushi, will you be my new lover? :<
User avatar
Chiprel
 
Posts: 778
Joined: Wed Aug 01, 2012 1:25 am

Re: LowGfx.res mod

Postby darnokpl » Tue Dec 04, 2012 11:05 pm

Chiprel wrote:Can you login there without my custom_res and make printscreen of that biome? So I can see exactly which .res might be causing it. If I recall right we have 2-3 swamp textures :P

For now you can try deleting:
yourUSER/salem/custom_res/gfx/tiles/swamp.res and swamp2.res and see if it changes anything.


That can be a problem, I renamed folder to play again on higher res and ported to home:/
Image
User avatar
darnokpl
 
Posts: 2019
Joined: Thu Aug 02, 2012 12:10 am

Re: LowGfx.res mod

Postby _Gunnar » Tue Dec 04, 2012 11:08 pm

Chiprel wrote:Can you login there without my custom_res and make printscreen of that biome? So I can see exactly which .res might be causing it. If I recall right we have 2-3 swamp textures :P

For now you can try deleting:
yourUSER/salem/custom_res/gfx/tiles/swamp.res and swamp2.res and see if it changes anything.


I'll do this when I get a chance to play.
ImageImageImage
Darwoth wrote:tradewinds is gunnar
Brego wrote:***** STUPID GUNNAR!

great minds
User avatar
_Gunnar
 
Posts: 520
Joined: Wed Aug 01, 2012 9:21 pm

Re: LowGfx.res mod

Postby _Gunnar » Tue Dec 04, 2012 11:22 pm

Image

Deleting both swamp.res and swamp2.res fixed the crash, however deleting either one did not, which is a little odd (but I'm probably misunderstanding stuff).
ImageImageImage
Darwoth wrote:tradewinds is gunnar
Brego wrote:***** STUPID GUNNAR!

great minds
User avatar
_Gunnar
 
Posts: 520
Joined: Wed Aug 01, 2012 9:21 pm

Next

Return to Artifice & Arcana

Who is online

Users browsing this forum: No registered users and 3 guests

cron