Latikai client crash (inventory related?)

Forum for game modifications and custom clients.

Latikai client crash (inventory related?)

Postby JonathJCen » Thu Mar 10, 2016 11:08 pm

Howdy. I'm getting the following Haven Error

java.lang.IllegalArgumentException: Comparison method violates its general contract!
at java.util.TimSort.mergeHi(Unknown Source)
at java.util.TimSort.mergeAt(Unknown Source)
at java.util.TimSort.mergeCollapse(Unknown Source)
at java.util.TimSort.sort(Unknown Source)
at java.util.Arrays.sort(Unknown Source)
at java.util.ArrayList.sort(Unknown Source)
at java.util.Collections.sort(Unknown Source)
at haven.Inventory.sortItemsLocally(Inventory.java:187)
at haven.Inventory.resort(Inventory.java:372)
at haven.GItem.uimsg(GItem.java:255)
at haven.UI.uimsg(UI.java:252)
at haven.RemoteUI.run(RemoteUI.java:71)
at haven.MainFrame.run(MainFrame.java:291)
at java.lang.Thread.run(Unknown Source)

I'm not familiar with Java so I need a hand figuring out how to fix this.

What actions are causing the crash:
The Client will crash at random intervals whenever a new item is added to my inventory. This happens when I: Harvest from any plant; Pick up something off the ground; Split a log or pick brake up a pinecone; etc.

Sorting issue, perhaps?
I am using inventory sorting and I believe it may be related to it. For me this is a huge reason to use the client and I'd really like to find a fix.
JonathJCen
 
Posts: 3
Joined: Sat Feb 09, 2013 8:44 pm

Re: Latikai client crash (inventory related?)

Postby Kandarim » Fri Mar 11, 2016 1:11 am

quick fix: revert to Java7
Actual fix: wait for me to finally figure out why the hell Java is still throwing these errors when I told it to use Java 7 sorting.
I have neither the crayons nor the time to explain it to you.
JC wrote:I'm not fully committed to being wrong on that yet.
User avatar
Kandarim
Customer
 
Posts: 5227
Joined: Mon Jan 21, 2013 4:18 pm

Re: Latikai client crash (inventory related?)

Postby Kmab » Sun Mar 13, 2016 4:56 pm

I have similar problem. I cannot login to the game after last log out. I cleared cache, but no result.
Standard client works fine.

[quote]java.lang.NullPointerException
at haven.plugins.XTendedPaginae.loadPluginXTendedPaginae(XTendedPaginae.java:36)
at haven.plugins.XTendedPaginae.loadXTendedPaginae(XTendedPaginae.java:26)
at haven.MenuGrid.<init>(MenuGrid.java:127)
at haven.GameUI.<init>(GameUI.java:134)
at haven.GameUI$$_.create(GameUI.java:123)
at haven.Widget.makechild(Widget.java:246)
at haven.UI.newwidget(UI.java:178)
at haven.RemoteUI.run(RemoteUI.java:65)
at haven.MainFrame.run(MainFrame.java:291)
at java.lang.Thread.run(Unknown Source)[/quote
Vir prudens non contra ventum mingit
User avatar
Kmab
 
Posts: 12
Joined: Sun Aug 11, 2013 7:14 pm

Re: Latikai client crash (inventory related?)

Postby Taipion » Sun Mar 13, 2016 5:18 pm

Kmab wrote:I have similar problem. I cannot login to the game after last log out. I cleared cache, but no result.
Standard client works fine.

java.lang.NullPointerException
at haven.plugins.XTendedPaginae.loadPluginXTendedPaginae(XTendedPaginae.java:36)
at haven.plugins.XTendedPaginae.loadXTendedPaginae(XTendedPaginae.java:26)
at haven.MenuGrid.<init>(MenuGrid.java:127)
at haven.GameUI.<init>(GameUI.java:134)
at haven.GameUI$$_.create(GameUI.java:123)
at haven.Widget.makechild(Widget.java:246)
at haven.UI.newwidget(UI.java:178)
at haven.RemoteUI.run(RemoteUI.java:65)
at haven.MainFrame.run(MainFrame.java:291)
at java.lang.Thread.run(Unknown Source)[/quote


Same for me, had a client running, and tried to log in another char, I noticed there was some kind of update when starting the client, and since then I only get this error and can not log in with Latikais on any character.
Need something? Here is my Shop (Including some useful info for new/returning players at the bottom of the first post)
Taipion
 
Posts: 1852
Joined: Fri Mar 08, 2013 4:12 pm

Re: Latikai client crash (inventory related?)

Postby Kandarim » Sun Mar 13, 2016 5:19 pm

should be fixed now. Is it still an issue? Bad timing, I kinda forgot no-one else would have the plugins folder yet (experimental feature :) )
I have neither the crayons nor the time to explain it to you.
JC wrote:I'm not fully committed to being wrong on that yet.
User avatar
Kandarim
Customer
 
Posts: 5227
Joined: Mon Jan 21, 2013 4:18 pm

Re: Latikai client crash (inventory related?)

Postby Kuulikindel1 » Sun Mar 13, 2016 5:22 pm

I cant log in now

java.lang.NullPointerException
at haven.plugins.XTendedPaginae.loadPluginXTendedPaginae(XTendedPaginae.java:36)
at haven.plugins.XTendedPaginae.loadXTendedPaginae(XTendedPaginae.java:26)
at haven.MenuGrid.<init>(MenuGrid.java:127)
at haven.GameUI.<init>(GameUI.java:134)
at haven.GameUI$$_.create(GameUI.java:123)
at haven.Widget.makechild(Widget.java:246)
at haven.UI.newwidget(UI.java:178)
at haven.RemoteUI.run(RemoteUI.java:65)
at haven.MainFrame.run(MainFrame.java:291)
at java.lang.Thread.run(Unknown Source)
User avatar
Kuulikindel1
 
Posts: 149
Joined: Tue Aug 11, 2015 6:17 am

Re: Latikai client crash (inventory related?)

Postby Kandarim » Sun Mar 13, 2016 5:24 pm

I fixed this 7 minutes ago, and it's now working for me just fine. delete ~/Salem/bin and try again if it is still not working for you.
I have neither the crayons nor the time to explain it to you.
JC wrote:I'm not fully committed to being wrong on that yet.
User avatar
Kandarim
Customer
 
Posts: 5227
Joined: Mon Jan 21, 2013 4:18 pm

Re: Latikai client crash (inventory related?)

Postby Kuulikindel1 » Sun Mar 13, 2016 5:31 pm

Kandarim wrote:I fixed this 7 minutes ago, and it's now working for me just fine. delete ~/Salem/bin and try again if it is still not working for you.

That worked, Thank you.
User avatar
Kuulikindel1
 
Posts: 149
Joined: Tue Aug 11, 2015 6:17 am

Re: Latikai client crash (inventory related?)

Postby mgwerner » Mon Mar 14, 2016 10:12 am

Kandarim wrote:I fixed this 7 minutes ago, and it's now working for me just fine. delete ~/Salem/bin and try again if it is still not working for you.

I had the same issue, fix seems to have worked.

My crash happened only when a new item not put in inventory since my reinstall was placed, making a ? and then crashing. Restarting the client cleared the ? and it would work fine until the next new item.

So, either I have gone through all the items and there is no more issue (rendering?), or the fix cleared it up.

Edit: Just got a new item, Spooky Mushroom, started with a ? and then rendered, no crash.

Thanks for the fast fix.
User avatar
mgwerner
 
Posts: 41
Joined: Fri Dec 25, 2015 5:55 pm
Location: Chengdu, Sezhuan, China

Re: Latikai client crash (inventory related?)

Postby Kandarim » Mon Mar 14, 2016 10:34 am

that is not related to any of the recent fixes. Sounds like you simply had some networking issues.
For future reference, such discussions are better at home on my thread.
I have neither the crayons nor the time to explain it to you.
JC wrote:I'm not fully committed to being wrong on that yet.
User avatar
Kandarim
Customer
 
Posts: 5227
Joined: Mon Jan 21, 2013 4:18 pm

Next

Return to Artifice & Arcana

Who is online

Users browsing this forum: No registered users and 3 guests