Ubuntu 16.04 invisible mouse

Forum for bugs and technical problems.

Ubuntu 16.04 invisible mouse

Postby Forungi » Tue Aug 08, 2017 7:44 pm

Just did a fresh install of Ubuntu 16.04 LTS and on every client (Original, Latikai and Ender) I get the issue that inside the client window my mouse flickers and turns invisible, but I can still click on things though it's a tedious process.

Anyone experience anything similar? Can't seem to find a solution anywhere.
Forungi
 
Posts: 688
Joined: Tue Jun 23, 2015 3:31 pm

Re: Ubuntu 16.04 invisible mouse

Postby lachlaan » Wed Aug 09, 2017 3:30 pm

If your Ubuntu thingy uses OpenJDK try installing Oracle Java, say some other threads around. If not wait for a reply from JC or try pestering Loftar in the Haven forums as they might know of solutions for such things as well xD
lachlaan
Customer
 
Posts: 1867
Joined: Tue Mar 12, 2013 3:11 pm

Re: Ubuntu 16.04 invisible mouse

Postby Kandarim » Wed Aug 09, 2017 4:23 pm

switching to oracle java should be the first step if you want to run anything serious in Java, but aside from that: when it is flickering, do you see your normal mouse, or a different sprite for the mouse? (The client uses different sprites, maybe they are not loaded/displayed correctly?)

I myself am running linux (although KDE Mint, not Ubuntu), while original development (loftar) was also done on linux. The client should in general be linux-compatible.
I have neither the crayons nor the time to explain it to you.
Fiduciani wrote:You can trust us. We're the good guys.
User avatar
Kandarim
Customer
 
Posts: 5197
Joined: Mon Jan 21, 2013 4:18 pm

Re: Ubuntu 16.04 invisible mouse

Postby Forungi » Wed Aug 09, 2017 6:11 pm

I installed the OracleJDK and also made sure that my java config was currently using that instead of OpenJDK, sadly no success.
Mouse is still invisible in client, when it flickers from time to time I can't make out the texture so I wouldn't be able to say if it's a different one.

Might try doing a fresh install of some other linux system.
Forungi
 
Posts: 688
Joined: Tue Jun 23, 2015 3:31 pm


Return to Bugs & Technicalities

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests